View Single Post
  #2  
Old 27th December 2010, 13:17
entertheraptor entertheraptor is offline
Member
 
Join Date: Dec 2010
Location: Melbourne, Australia
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to entertheraptor
Default

OK, now things are really screwed up!

I went back to using the file /etc/apache2/conf.d/roundcube.conf as described above and was still getting the error 500. Whether it was a good idea or not I decided to change this file to point to the squirrelmail instillation instead to see if that worked figuring it may give me some indication as to whether the problem was with roundcube (or something associated) itself or with the roundcube.conf file.

When I changed the roundcube.conf file to point to the squirrelmail instillation what happened was when I went to "mydomain.com/mailbox" the browser (Chrome) downloaded the index.php file in the squirrelmail directory instead of opening it.

So I changed the roundcube.conf file back to it's original settings (pointing to /var/www/mail) expecting it to go back to throwing a 500 error and it still downloads the squirrelmail index.php.

This behavior has continued after refreshing the browser, restarting apache and even rebooting the server.

I'm now at a complete loss.

(Update)
I got past this (or something did, still not sure how) and now we are back to getting the error 500. I have searched through error logs and the only thing I could find was in /var/log/ispconfig/httpd/mydomain.com/error.log which reported as follows...

[Mon Dec 27 21:19:58 2010] [error] [client 192.168.1.2] SoftException in Application.cpp:221: File "/var/www/mail/index.php" is not in document root of Vhost "/var/www/mydomain.com/web"

...and that's all she wrote!

Some assistance with this issue would be greatly appreciated.

Last edited by entertheraptor; 27th December 2010 at 23:39. Reason: Update
Reply With Quote