View Single Post
  #10  
Old 21st December 2010, 16:51
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi, For a long time I haven't solved DNS problem. I start from begin.

I have Debian lenny ISPConfig 3.0.3.1 with myDNS. Created NSSet at domain registrator with glue records to my server IP. Server has open all ports (is in DMZ zone). Configured myDNS SOA with correct records. Correct hostname, static IP address. I dont know where is problem why online tools, dig, etc... shows that dns server is down at domain electrohost.cz. My hostname is server.electrohost.cz. Firts i look at netstat.

Quote:
netstat -tap | grep dns

tcp 0 0 server.electroho:domain *:* LISTEN 3478/mydns
tcp 0 0 localhost:domain *:* LISTEN 3478/mydns
tcp6 0 0 localhost:domain [::]:* LISTEN 3478/mydns
I think its okay.

Next resolv.conf

Quote:
cat /etc/resolv.conf
nameserver 192.168.1.1
nameserver 93.185.0.141
First name server is my router with DNS from ISP and next is my Public IP address my server.

Ports are open i tried it. DNS records are also in correct form with my own NS. ISPConfig shows all services online.
Looks like DNS server must work when i type address in browser but it doesn't work. I tried everything, 3 times reinstalled server with bind, mydns but same problem. I don't know where is problem. All is up, configured... I hope that anybody help me. At last i'm going to contact my ISP if block my services, i don't know. I know its my problem but I really dont know what to do I hope in some good idea. Thank you really for any help.
Reply With Quote