View Single Post
  #3  
Old 15th December 2010, 14:54
holykim holykim is offline
Member
 
Join Date: Jan 2009
Posts: 56
Thanks: 17
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
I've moved your post to the dev forum now as it is only related to the API.

Here are the changes that we did in the API:

ISPConfig 3.0.2.2:

client_update($session_id, $reseller_id, $client_id, $params)

ISPConfig 3.0.3:

client_update($session_id, $client_id, $reseller_id, $params)

In your code, did you exchange the variable order where you call this function already?
Hi Till

Thanks for moving my post to Dev forum.

Yes, I did and had a Soap error 'Wrong version' so I tried to find the reason for the error from remote.inc.php.

I changed code (just exchanged $reseller_id and $client_id) as below and it's working without error.

$affected_rows = $this->updateQuery('../client/form/client.tform.php', $reseller_id, $client_id, $params);


Thanks

Harry
Reply With Quote