View Single Post
  #1  
Old 8th December 2010, 13:35
MrM MrM is offline
Member
 
Join Date: Oct 2008
Location: Ljubljana, Slovenia
Posts: 58
Thanks: 6
Thanked 0 Times in 0 Posts
Default MyDNS notify not working

I know this has been discussed a million times, but I just can't get it working.

I'm running ISPconfig 3.0.3 (just upgraded from 3.0.1.6) on Ubuntu 9.04. On this server, I have MyDNS 1.2.8.27 as the master DNS. Then I have a second server running bind9 on Ubuntu 10.04 as the slave DNS (no ISPconfig here).

On the master (MyDNS) I have:
Code:
allow-axfr = yes
allow-tcp = yes
allow-update = yes
notify-enabled = yes
notify-source = 0.0.0.0
Also, each zone has the slave's IP in the xfer field.

On the slave (bind9) I have:
Code:
server <MASTER_IP> {
    request-ixfr no;
};
As well as all the zones from the master like this:
Code:
zone "<DOMAIN>" {
    type slave;
    file "/var/cache/bind/db.<DOMAIN>";
    masters { <MASTER_IP>; };
};

The problem is, the slave only receives notifies when MyDNS is restarted on the master. However, if I change a DNS record in ISPconfig, no notification is sent to the slave, and consequently the slave does not receive the updated record. If I run `rndc retransfer <DOMAIN>` on the slave, the record gets updated.

What could be the cause of this problem?
Reply With Quote
Sponsored Links