View Single Post
  #1  
Old 4th December 2010, 16:49
kevin186 kevin186 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 1
Thanked 4 Times in 3 Posts
Default SuEXEC + Fast-CGI = upload error 500

I just finished a new installation of fedora 14 with ispconfig 3 following the perfect server tutorial and I ran into a problem. When I had my websites set to suexec + fast-cgi, I would get error 500 when uploading any files. This happened to my wordpress and slideshowpro director installations. I could not figure it out at first and decided to completely reinstall fedora 14, which still produced the same error and generated the following log:
Code:
[Sat Dec 04 00:39:11 2010] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: HTTP request length 132532 (so far) exceeds MaxRequestLen (131072), referer: http://example.com/wp-admin/themes.php?page=custom-background
The solution was to add the following code to apache directives in the options tab for the website:
Code:
<IfModule mod_fcgid.c>
MaxRequestLen 15728640
</IfModule>
I don't know the cause of this error because my jpeg was not large at all, maybe 500kb. I was able to upload using any other php option for the websites, such as mod-php, cgi, suphp. I found the tip at the following website:http://www.blogtorrent.de/2010/11/30...estlen-131072/
Reply With Quote
Sponsored Links