View Single Post
  #17  
Old 30th November 2010, 06:21
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 368
Thanks: 25
Thanked 47 Times in 42 Posts
Default

Hate to resurrect this thread, but I ran into a similar issue. I had followed the equivalent tutorial for Ubuntu 10.04

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

from page 3 onward only (because my VPS was already provisioned with Ubuntu 10.04). STARTTLS was working "out-of-the-box", but SSL/TLS was not.

I chose to install postfix and dovecot (instead of courier), and wanted to be able to use both STARTTLS and SSL/TLS. (My ISP doesn't permit me to send outgoing mail via my own server over port 25, which is why I wanted to be able to send outgoing mail on another port, e.g., 465.)

If the original user hasn't solved his own problem by now, do you have all of these packages installed? The 10.04 tutorial (and I assume the one you followed for 9.10) doesn't get into SSL/TLS and the SASL modules.

Code:
apt-get install libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql
If so, and you've commented the lines in
Code:
/etc/postfix/master.cf
that till suggested, incoming POP3 email should be fetched on port 995, and outgoing SMTP email should be sent on port 465.

I just tried all of this and it works perfectly well for me on Ubuntu 10.04.
Reply With Quote