View Single Post
  #1  
Old 14th November 2010, 11:08
menahem menahem is offline
Member
 
Join Date: Aug 2006
Posts: 40
Thanks: 0
Thanked 1 Time in 1 Post
Default Using cgi-bin directory outside ispconfig installation

Hi all,

As you all know ispconfig uses jalkit in order to chroot web-server as well as mail server erc. That is fine, but: i am experiencing a problem with other application we use cgi-bin directory outside the chrooted system.

In order to pin-point the problem i will give 2 examples (one solved and one did not)

Example 1 mailgraph (This tutorial --> http://howtoforge.net/mail_statistic...ph_pflogsumm):
Mailgraph installation put out cgi-bin files at:/usr/lib/cgi-bin/. If you use the tutorial you will not see any graph because the web-site user is jailed under the web-site directory. In this case i re owned the files at /usr/lib/cgi-bin/ to the web-server user (i.e webX.clentY) and it worked out fine.

Example 2 BackupPC: (this tutorial --> http://howtoforge.net/linux_backuppc) once again cgi-bin files are outside the chrooted web server. I build up the web server user at backuppc installation but it is not working at all.

Another problematic app is nagios who ,once again, put cgi-bin directive out side the chrooted system, and once again (although i owned the cgi-bin directory to web server jailed user) it is not usable.

I will be more the happy if some one has a way howto fix the problem of cgi-bin outside the chrooted web-server user.

B.T.W: in the case of nagios i chaned the apache.conf file that came with the installation so that it will point to the chrooted cgi-bin and made the other needed changes with nagion, never the less it did not worked out nagios did not liked is. I think their should be more system wise solution so that jailed web-site user could read run and activate cgi-bin directories out side jail.

A word about the installation:

O.S: Ubuntu 10.04.1 32 bit web server.Ispconfig3 version 3.0.3

Thank you all,

Menahem
Reply With Quote
Sponsored Links