View Single Post
  #3  
Old 2nd November 2010, 06:14
maineac maineac is offline
Junior Member
 
Join Date: Oct 2010
Location: Near Chicago
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to maineac
Default

falko,

I've gone a little beyond that now. But I ran "Killall cgi-php" as root and found no cgi-php process running.

One thing that wasn't clear on the Ubuntu 10.4 Howto or the Cherokee documents is how to set the URL you want to use for your virtual server. I've figured this out with the help of some folks on //freenode.irc#cherokee.

If you set the Nickname of the server to "home.myserver.net" and Host Match method to "Match Nickname" the URL will be "http://home.myserver.net". Note that any string you use will work PROVIDED the string maps to an IP address, either in your DNS or your hosts file.

I have verified that php works on a command line

I have verified that Firefox will find an html file on my URL through the Cherokee server by adding an index.html and setting the Directory Indexes to "index.php,index.html".

Now if I use the URL without a file I get the 404 URL not found error. (i.e. http://myserver.test)

If I add the index.html (http://myserver.test/index.html) I get the static webpage, index.html.

My Settings are:

Under the Rulesets, the Extensions PHP rule handler is FastCGI, the Document Root is "/usr/lib/cgi-bin" (which does contain a link named 'php' to php5). The "Information Services" is set to Nick:"PHP Interpreter", Host: 127.0.0.1:47990.

Any ideas on why it doesn't work?
Reply With Quote