View Single Post
  #2  
Old 25th October 2010, 04:07
diverbelow diverbelow is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by diverbelow View Post
I used Perfect Ubuntu 10.04.1 ISPConfig 2 setup (by the way which is awesome) and I got everything working and setup the first 6 domains.

Spam kept coming in, and I followed this to give the users ISPConfig 2.x: How To Add a "Move to SPAM"-Option To Your ISPConfig Installation and it went great. Still did not, but gave users more options.

Today, when I added a new website and creating the client went good, but when creating the site, I get this message when creating a new user in email:
Fatal error: Call to undefined method isp_user::user_insert() in /home/admispconfig/ispconfig/web/multidoc/edit/edit.php on line 332

I also noticed that in /var/www it does not create the symlink or folders for my new site. Also, ISPConfig does not add the new account in /etc/passwd and in the vhost file in apache2.

When I try to deleting a user email I get the following error message:
Fatal error: Call to undefined method isp_user::user_delete() in /home/admispconfig/ispconfig/lib/classes/ispconfig_tree.lib.php on line 148

In the recycle bin, the website I deleted shows up; so I empty the recycle bin and minutes later, the same files are there.

Those instructions I followed to move, delete the spam I forgot to make a copy of those files I changed.

Any ideas that will help? Thanks in advance,
Rick
So, what I did was to fix my issue, was to install the perfect ubuntu server setup in a VM and install ISPConfig 2, and copy over the files I changed in How To Add a "Move to SPAM" from the files ISPConfig in the VM.

I was able to add the website and the information for that website.

About the spam: If spam keeps coming in, check out this page: anti spam not working that really works GREAT! Just wish I search prior.
Reply With Quote