View Single Post
  #1  
Old 6th October 2010, 23:48
md@waw.co.uk md@waw.co.uk is offline
Junior Member
 
Join Date: May 2006
Posts: 25
Thanks: 3
Thanked 1 Time in 1 Post
Default vhosts issue after upgrading from 3.0.2 to 3.0.3 - no server

I have just upgraded to 3.0.3 (on a testing server)

Apache is not working

When I try to restart Apache2 I get this error message

*********** START MESSAGE ************

Restarting web server: apache2Syntax error on line 6 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
Listen requires 1 or 2 arguments.

*********** END MESSAGE **************

This is the vhosts file


################################################## ####
# This virtual host contains the configuration
# for the ISPConfig controlpanel
################################################## ####

Listen apt-get install sudo

NameVirtualHost *:apt-get install sudo

<VirtualHost _default_:apt-get install sudo>
ServerAdmin webmaster@localhost

<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
SuexecUserGroup ispconfig ispconfig
<Directory /var/www/ispconfig/>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
Order allow,deny
Allow from all
</Directory>
</IfModule>

<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
AddType application/x-httpd-php .php
<Directory /usr/local/ispconfig/interface/web>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
php_value magic_quotes_gpc 0
</Directory>
</IfModule>

# ErrorLog /var/log/apache2/error.log
# CustomLog /var/log/apache2/access.log combined
ServerSignature Off

<IfModule mod_security2.c>
SecRuleEngine Off
</IfModule>

# SSL Configuration
#SSLEngine On
#SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
#SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&& END VHOST FILE

Can anyone kindly tell me what's wrong

thanks
Reply With Quote
Sponsored Links