View Single Post
  #3  
Old 3rd October 2010, 18:31
Hamra Hamra is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the reply. ok, i think i jumped to conclusions fast. i took the time to read the configuration files, and i noticed how everything is corect, even the sites-enabled is mentioned in httpd.conf.
and thanks for the IP tip, indeed, i was having an overlap problem when using IPs.
so all done, i setup 2 websites. one for domain.com, with auto-subdomain www.domain.com, and another website for info.domain.com, which i want it to run phpsysinfo.
i unchecked suExec, and set it to use suPHP.
i got a 500 error while trying to load it. i looked in its error log, and saw a complaint that index.php is writeable by others. so i went to "/etc/suphp.conf", and changed the security options regarding others, to "true".
loaded the page, another 500 error, but now different one in the error log. a complaint that index.php is having an ID below min_id.
a little googling, and i founf its talking about owner's UID, my files are owned by root (i put them there using a root SSH shell). i changed ownership to "apache", which still resulted in same error (apache turned out to be very low too), so i changed min_id to 10.
again, another 500 error, this time that the directory "web" is not owned by apache... by that time, i was really getting pissed off, specially that it's asking for it to be owned by apache, while apache is lower than the min_id, anyway, i complied and changed ownership from webX:clientX into apache:apache.
tried loading the page, and it loaded fine.

but now to the point.... i hardly think what i've done is an optimal solution, but more of dirty hacking. what IS the appropriate way of dealing with suPHP and ISPconfig/apache?
Reply With Quote