View Single Post
  #1  
Old 2nd October 2010, 22:57
MBAngel MBAngel is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default php and phpmyadmin not working

I am helping a friend set up their server. I do most of my helping from ssh, so I'll need a clue how to post things like logs and config files.

We've tried for 2 weeks on this, searching the forums and the web for more info. This is our second clean install.


Php and phpmyadmin are broken. We set up the server following the perfect debian server guide. http://www.howtoforge.com/perfect-se...nny-ispconfig3

This is a single server setup.

I can not access myphpadmin from ipaddress/myphpadmin, ipaddress:8080/myphpadmin nor from domainname/myphpadmin or domainname:8080/myphpadmin

I put a php file in a web site which was created thru ispconfig to test if mysql is responding, and ftp works, as I was able to post the file on that web site. I see only the code - which means php is not working.

I find it interesting that on the phpmyadmin site, the install directions say to have php, apache and mysql installed first, yet the perfect server directions install php after phpmyadmin.

I am eagerly following this thread - http://www.howtoforge.com/forums/sho...t=49100&page=2
I don't want to hijack someone else's thread tho, that gets confusing for people who want to resolve their issue by reading the forum.

locate phpmyadmin.conf
Code:
/var/lib/dpkg/info/phpmyadmin.conffiles
/var/lib/dpkg/info/phpmyadmin.config
I can't seem to find a copy of what phpmyadmin.conf should read by default. I tried to copy /var/lib/dpkg/info/phpmyadmin.config to /etc/apache2/conf.d/phpmyadmin.conf and I still can't see phpmyadmin, and it caused errors in apache restarting.

ls -la /etc/apache2/conf.d seems to indicate all files are owned by root, total 28

Errors in the apache error log indicate that /var/www/phpmyadmin directories do not exist.


when I do netstat - tap


Code:
tcp	0	0	localhost.localdo:35748	localhost.locald:domain	TIME_WAIT
tcp	0	0	localhost.localdo:36724	localhost.localdoma:ftp	TIME_WAIT
tcp	0	0	localhost.localdo:55088	localhost.localdoma:www	TIME_WAIT
tcp	0	0	localhost.localdo:mysql	localhost.localdo:42868	TIME_WAIT
tcp	0	0	localhost.localdo:42868	localhost.localdo:mysql	TIME_WAIT
Then I get a long list of this
Code:
unix 3   [ ]    STREAM    CONNECTED   ####
unix 2   [ ]    DGRAM                 ####
some of them have directory info after them, like this:
Code:
unix 3   [ ]    STREAM    CONNECTED   #### /var/run/dbus/system_bus_socket
getenforce returns "command not found"


iptables -L

Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination 
fail2ban-ssh tcp -- anywhere	anywhere        

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

chain fail2ban-ssh (1 references)
target     prot opt source               destination
RETURN	all  --  anywhere 		anywhere
dpkg-reconfigure phpmyadmin - I ran this and chose apache2 in the box and it ran with no errors, but nothing has changed after restart of apache


So, overall it appears to me that the apache, php and phpmyadmin installs went slightly wonky. How can I fix this?

Other questions:
1 how do I make it so /webmail works for all domains?
2 how are outlook settings configured - taking into consideration that I followed the tutorial and have made no customizations - if username is user1 and client name is test and the user id is 1?
3 Can I change the default email login to username@domainname.com?
Reply With Quote
Sponsored Links