View Single Post
  #3  
Old 25th April 2006, 22:29
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default Starting up saslauthd

Hello there, i had the same problem with my Debian system.
This worked for me, maybe it is also helpful to you:

Edit /etc/default/saslauthd:

START=yes
MECHANISMS=''pam''

saslauthd is not started after package installation (we’ll do it later)!
Next file to edit is /etc/postfix/sasl/smtpd.conf:

pwcheck_method: saslauthd

Add the next few lines in /etc/postfix/main.cf to enable SASL:

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes

smtpd_recipient_restrictions =
permit_sasl_authenticated,
permit_mynetworks,
reject_unauth_destination

postfix does a chroot so it can’t communicate with saslauthd. This is the tricky part:

rm -r /var/run/saslauthd/
mkdir -p /var/spool/postfix/var/run/saslauthd
ln -s /var/spool/postfix/var/run/saslauthd /var/run
chgrp sasl /var/spool/postfix/var/run/saslauthd
adduser postfix sasl

Now restart postfix and start saslauthd

/etc/init.d/postfix restart
/etc/init.d/saslauthd start


Hans
Reply With Quote