View Single Post
  #6  
Old 22nd September 2010, 11:36
staatslot staatslot is offline
Junior Member
 
Join Date: Aug 2010
Posts: 10
Thanks: 1
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by u4david View Post
just little more detail .Thank you.
no problem.
Open the /usr/local/ispconfig/server/conf/vhost.conf.master file on your webserver, not the server ispconfig is running. Browse to the part that reads
Code:
###########################################################
# SSL Vhost
###########################################################
locate this piece of code:
Code:
<tmpl_if name='suexec'op='==' value='y'>
    # suexec enabled
    SuexecUserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
</tmpl_if>
beneath it repace with:

Code:
# Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
<tmpl_if name='php' op='==' value='mod'>
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@<tmpl_var name='domain'>"
    php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
    php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
<tmpl_if name='security_level' op='==' value='20'>
    php_admin_value open_basedir <tmpl_var name='php_open_basedir'>
</tmpl_if>
</tmpl_if>
<tmpl_if name='php' op='==' value='suphp'>
    # suphp enabled
    <Directory {tmpl_var name='web_document_root'}>
        suPHP_Engine on
        # suPHP_UserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
    </Directory>
</tmpl_if>
that does the trick. but according to till it will be fixed in a next release as he added it to the bugtracker.
Reply With Quote