View Single Post
  #1  
Old 19th September 2010, 22:44
juan_g juan_g is offline
Junior Member
 
Join Date: Sep 2010
Posts: 19
Thanks: 7
Thanked 1 Time in 1 Post
Default Problem sending mail when not installing amavisd-new

Just a note mentioning an email problem and a solution I've just found, because I think probably other users not installing amavisd-new will be affected by it, maybe without finding the cause.

I'm testing ISPConfig 3 on a VPS. First I tried with Ubuntu, and now with Debian installing everything from scratch, since Debian seems the most supported Linux distribution for ISPConfig. I've followed The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3].

I skipped the step 10 "Install Amavisd-new, SpamAssassin, And Clamav", since I will use ISPConfig to send mail (SMTP), and Google Apps (the free Standard edition for this test site) to receive it. This will save resources on the VPS, letting Google take care of spam and viruses.

However, not installing amavisd-new caused email to be blocked in the mail queue: Monitor -> Logfiles -> Show Mail Queue, with the error "connect to 127.0.0.1[127.0.0.1]:10024: Connection refused".

According to Wikipedia's List of TCP and UDP port numbers, that port (10024) is used for SMTP, to Amavis from Postfix. The solution was in Remove Amavis Content Filter From Postfix Configuration, Requeue All Postfix Email Messages, that is commenting out a few lines of Postfix configuration for Amavis, in the files main.cf and master.cf of the /etc/postfix directory, reloading Postfix, and requeueing blocked messages.

That fixed it, with SMTP working fine now without Amavisd-new, SpamAssassin, and Clamav.

Maybe this solution could be automated in next ISPConfig 3 releases, detecting if amavisd-new is installed or not, and modifying configuration files accordingly.

As a side note, I think it would be helpful to have some brief documentation with examples to configure email clients (Thunderbird, etc.) to work with email accounts created by ISPConfig. I didn't find any mention about this. With a mailbox such as test@example.com, I was trying "test" as user name for the SMTP configuration in Thunderbird. The correct setting, for Thunderbird and SquirrelMail, was "test@example.com" as the user name (this is different for other SMTP servers I'm using). Solving this authentication problem led to be able to solve the other, related to amavisd-new.

Last edited by juan_g; 19th September 2010 at 23:27. Reason: Email client configuration
Reply With Quote
Sponsored Links