View Single Post
  #1  
Old 19th September 2010, 15:04
staatslot staatslot is offline
Junior Member
 
Join Date: Aug 2010
Posts: 10
Thanks: 1
Thanked 2 Times in 1 Post
Default suphp + ssl runs as www-data

Hi all,

I think I've found a nasty bug in ISPconfig 3.0.2.2.
When a site that has suphp enabled runs at port 443 (SSL) php doens't run as the suphp user, but as www-data. When displaying that same site at port 80 (with no settings altered) it runs as the suphp user.

I took a look at the vhost file of the sites I noticed this difference:

PORT 80
Code:
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # suphp enabled
    <Directory /var/www/clients/client17/web22/web>
        suPHP_Engine on
        # suPHP_UserGroup web22 client17
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
    </Directory>
PORT 443
Code:
    suPHP_Engine on
    # suPHP_UserGroup web22 client17
    AddHandler x-httpd-suphp .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-suphp
The configuration file (php.ini) path is also different for both ports when running phpinfo().
PORT 80
Code:
/etc/php5/cgi
PORT 443
Code:
/etc/php5/apache2
Changing the vhost files does the trick, so my best guess is ISPconfig is lacking to write the correct code to the vhost file for the SSL part of a website.

Any help is very much appreciated!
Reply With Quote
Sponsored Links