View Single Post
  #1  
Old 18th September 2010, 23:01
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 169
Thanks: 11
Thanked 9 Times in 9 Posts
Unhappy apache cannot start after creating a new site

I made a new site yesterday with all default settings, didn't touch anything except I created a db for it to mess with some old db I had etc.

today I run ubuntu again and apache won't start
I run:
/etc/init.d/apache2 start

and get:

Code:
 * Starting web server apache2                                                                                                                                                                                    Warning: DocumentRoot [/var/www/example.bounceme.net/web] does not exist
Syntax error on line 54 of /etc/apache2/sites-enabled/example.bounceme.net.vhost:
can't get fastcgi file info: /var/www/php-fcgi-scripts/web2/.php-fcgi-starter(/var/www/php-fcgi-scripts/web2/.php-fcgi-starter), errno: 2
                                                                                                                                                                                                           [fail]


contents of example.bounceme.net.vhost are:

Code:
<Directory /var/www/example.bounceme.net>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/example.bounceme.net/web
  
    ServerName example.bounceme.net
    ServerAdmin webmaster@example.bounceme.net

    ErrorLog /var/log/ispconfig/httpd/example.bounceme.net/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
    
    <Directory /var/www/example.bounceme.net/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client3/web2/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      # SocketPath /tmp/fcgid_sock/
      IdleTimeout 3600
      ProcessLifeTime 7200
      # MaxProcessCount 1000
      DefaultMinClassProcessCount 3
      DefaultMaxClassProcessCount 100
      IPCConnectTimeout 8
      IPCCommTimeout 360
      BusyTimeout 300
    </IfModule>
    <Directory /var/www/example.bounceme.net/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client3/web2/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web2 client3
    </IfModule>


</VirtualHost>

any help please ? I am noob and only solution for me without a help will be to reinstall server ... much mess !
any help appreciated

Last edited by orasis; 21st September 2010 at 17:27.
Reply With Quote
Sponsored Links