View Single Post
  #4  
Old 10th September 2010, 11:49
ratson ratson is offline
Junior Member
 
Join Date: Sep 2010
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by till View Post
This might happen if the doctype in the database is corrupted or the doctype does not match the installed ispconfig version. Download the latest isponfig 2.x version and run the update again.
thank you for the help, recreating the doctype table from script did it!

i think the problem with my updates is that the mysql user running the update scripts doesn't have the needed rights to process the script properly. i have just checked and the user has:
-all the rights to db_ispconfig,
-reload, show_db and create_user privilages on Server
-every right except drop on all databases
-every right on information_schema
-every right on mysql

is this correct?

here is the end of yesterdays update log
Code:
All prerequisites are fulfilled.
Here we go...

Connected successfully to db db_ispconfig
cp: stat "customized_templates/*" failed: No such file or directory
Restarting some services...
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Stopping ftp server: proftpd.
Starting ftp server: proftpd - setting default address to 127.0.0.1
.
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
it looks ok to me...

Last edited by ratson; 10th September 2010 at 11:57.
Reply With Quote