View Single Post
  #8  
Old 31st August 2010, 20:25
ejmarten ejmarten is offline
Junior Member
 
Join Date: Aug 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Try different MPM module

Have you tried installing apache with a different MPM module? If your website/webapp uses a connector to a multithreaded backend (ajp13?), you might want to try using the worker MPM.

#apt-get install apache2 apache2-doc apache2-mpm-worker apache2-utils libexpat1 ssl-cert

The error message itself might be a bug:
https://issues.apache.org/bugzilla/s...g.cgi?id=42829

The work around is to do a hard restart instead of a graceful restart when using mod_prefork.

If you have apache managing multiple ajp13 backend connections, I would try running mod_worker, not as a workaround to this bug, but for better performance and reliability.
Reply With Quote