View Single Post
  #33  
Old 22nd April 2006, 22:55
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko,

This is what I did (executed each line one-by-one):
=====================

apt-get install cyrus-sasl cyrus-sasl-crammd5 cyrus-sasl-devel cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-otp cyrus-sasl-plain cyrus-sasl-saslauthd

chkconfig --add saslauthd

/etc/init.d/saslauthd start

mkdir /etc/postfix/ssl

cd /etc/postfix/ssl/

openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024

chmod 600 smtpd.key

openssl req -new -key smtpd.key -out smtpd.csr

openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt

openssl rsa -in smtpd.key -out smtpd.key.unencrypted

mv -f smtpd.key.unencrypted smtpd.key

openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650

postconf -e 'mydomain = mileswork.com'

postconf -e 'myhostname = suse1.$mydomain'

postconf -e 'smtpd_sasl_local_domain ='

postconf -e 'smtpd_sasl_auth_enable = yes'

postconf -e 'smtpd_sasl_security_options = noanonymous'

postconf -e 'broken_sasl_auth_clients = yes'

postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains'

postconf -e 'inet_interfaces = all'

postconf -e 'alias_maps = hash:/etc/aliases'

postconf -e 'smtpd_tls_auth_only = no'

postconf -e 'smtp_use_tls = yes'

postconf -e 'smtpd_use_tls = yes'

postconf -e 'smtp_tls_note_starttls_offer = yes'

postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'

postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'

postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'

postconf -e 'smtpd_tls_loglevel = 1'

postconf -e 'smtpd_tls_received_header = yes'

postconf -e 'smtpd_tls_session_cache_timeout = 3600s'

postconf -e 'tls_random_source = dev:/dev/urandom'

=====================

After restarting postfix and
telnet localhost 25 and
ehlo localhost,
this is what I get:
=====================

suse1:~ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 suse1.mileswork.com ESMTP Postfix
ehlo localhost
250-suse1.mileswork.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

=====================

BTW, in ISPConfig.

1. Management TAB/Server/Settings:
Server Name : Suse1
Hostname : suse1
Domain : mileswork.com

And, in KMail. SMTP settings tabs.

1. Is it Port 25?
2. Server requires authentication selected. Used the same Login/Password as for POP setting.
3. Under the Security Tabs - Encryption = NONE, Authentication Method = LOGIN.
4. In the Sending Tab, do I set, Message Property = "Allow 8-bit" OR "MIME Compliant (Quoted Printable)"?

Is the above settings in KMail correct?

Thanks
Reply With Quote