View Single Post
  #4  
Old 19th August 2010, 15:43
AubreyKilian AubreyKilian is offline
Junior Member
 
Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up *Solved* SSL VirtualHost Oddity

Quote:
Originally Posted by AubreyKilian View Post
Hi All,

This is likely an Apache config issue and not an ispconfig one, but I was just wondering if anybody else has come across this issue before and what the solution was?
As I suspected, this was indeed not an ISPConfig problem, but an Apache/mod_ssl problem.
The default mod_ssl config file added a virtualhost called "_default_:443" - which took precedence over my new virtualhost that I created.
The _default_ one didn't have any documentroot or path information, just some SSL settings, including details for a server certificate. This information was picked up first.

Solution: Comment out/remove the whole _default_:443 virtualhost from the mod_ssl config file (/etc/httpd/conf.d/ssl.conf in my case on Centos 5)
Reply With Quote