View Single Post
  #1  
Old 19th August 2010, 13:42
yurnero yurnero is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Relay access denied (SASL support is not compiled in)

Hi,

I set up postfix with SMTP-AUTH on Fedora and I got "Relay access denied" when using a mail client such as outlook to send out an email. I also installed dovecot and roundcube on the system and I can send and receive an email on the roundcube webmail. It is worked properly. But I got the "Relay access denied" on sending an email from the mail client.

I tried to find out a problem and I read the thread, http://www.howtoforge.com/forums/arc...php/t-806.html and I also followed the chapter 10 in http://www.howtoforge.com/perfect-se...ispconfig-2-p4. It is pretty helpful. But the problem is still there. I tried to telnet on port 25 but I did not see the 250-STARTTLS and 250-AUTH PLAIN LOGIN yet. I also set smtpd_tls_loglevel = 14 in the main.cf and I see "warning: smtpd_sasl_auth_enable is true, but SASL support is not compiled in" and "warning: TLS has been selected, but TLS support is not compiled in" in the maillog. Can you guide me to to recompile postfix to support SASL and TLS?

Do I need to use the pam as described on http://www.howtoforge.com/virtual_po...ta_courier_p2?

What I need is an SMTP server that I can send out an email from a mail client with authorised users and I can also access mailbox from the roundcube webmail as it is worked fine now.
Reply With Quote
Sponsored Links