View Single Post
  #1  
Old 22nd April 2006, 17:56
papaqube papaqube is offline
Junior Member
 
Join Date: Feb 2006
Location: Manchester, UK
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default File Sharing Problem With Samba & (MS)ADS

Hi there

Linux newbie so please bare with me.

I am currently having some fun trying to set up an addition linux file server on my ADS domain .

Using samba i have managed to join the the linux box to the domain, i.e. 'net join ads'. No problems there, and it is now visable via 'neighbourhood network' on the windows side. I have set up a couple of shared folders on the linux box, which are also visable. However when I try to access the shares i have set up in samba i get a username and password prompt. When i enter user name and password I still cannot access the shares, and the prompt just re-appears . Here is my smb.conf:

[global]
workgroup = MYDOMAIN
realm = MYDOMAIN.NET
server string = samba file server
security = ADS
password server = win2ksvr1
log level = 3
log file = /var/log/samba/%m
max log size = 50
server signing = auto
printcap name = cups
preferred master = No
domain master = No
wins support = Yes
ldap ssl = no
idmap uid = 10000-20000
idmap gid = 10000-20000
winbind separator = +

[homes]
comment = Home Directories
valid users = %S
read only = No
browseable = No

[printers]
comment = All Printers
path = /tmp
guest ok = Yes
printable = Yes
browseable = No

[Public]
comment = Public
path = /home/samba/Public
valid users = @users, @MYDOMAIN+all, users
force group = users MYDOMAIN+all users
read only = No
create mask = 0660
directory mask = 0771

and my smbusers like this:

# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest
MYDOMAIN+testuser = testuser
users = MYDOMAIN+all users

I get a feeling that i have not set up the samba properly, i.e. password confirm, allowed users, etc. Also the file smbpasswd is empty.
Any help greatly appreciated. Thanks.
Reply With Quote
Sponsored Links