View Single Post
  #4  
Old 17th August 2010, 16:04
wahid wahid is offline
Junior Member
 
Join Date: Aug 2010
Location: Hamburg, Germany
Posts: 22
Thanks: 2
Thanked 3 Times in 2 Posts
Question

I'm getting the same problem with a simple backup.sh Script, which I tried to run with the default admin client to backup my website automatically.
So I went through the Cron-Menu in ISPConfig adding a record which contains:
Code:
0      0     *      *       0       web5    /var/www/clients/client0/web5/BackupScript.sh
I created previously a shell user for the concerned website, who has "none" for the Chroot Shell option.

When I looked into /var/log/ispconfig/cron.log, there was no output and some errors are shown:
Code:
/usr/local/ispconfig/server/scripts/create_jailkit_chroot.sh: line 24: jk_init: command not found
mkdir: cannot create directory `/var/www/clients/client0/web5/var': File exists
mkdir: cannot create directory `/var/www/clients/client0/web5/var/run': File exists
mkdir: cannot create directory `/var/www/clients/client0/web5/var/run/mysqld': File exists
ln: creating hard link `/var/www/clients/client0/web5/var/run/mysqld/mysqld.sock': File exists
/usr/local/ispconfig/server/scripts/create_jailkit_programs.sh: line 20: jk_cp: command not found
/usr/local/ispconfig/server/scripts/create_jailkit_programs.sh: line 20: jk_cp: command not found
/usr/local/ispconfig/server/scripts/create_jailkit_user.sh: line 25: jk_jailuser: command not found
usermod: no changes
When I run manually the script with the user "web5", everything works out of the box.

So what's missing?
Reply With Quote