View Single Post
  #1  
Old 22nd April 2006, 09:02
rbartz rbartz is offline
Member
 
Join Date: Apr 2006
Posts: 80
Thanks: 9
Thanked 6 Times in 5 Posts
Default Can't get SSL Cert to work

Hello again!

I recently installed ispConfig over a Perfect Setup Fedora Core3. After a few bumps we are pretty much running ok.

I installed a site and obtained an SSL cert based on the generated request. It is an IPSCA cert, which needs a chain certificate. I copied the chain cert to the site root and then tried to add the SSLCertificateChainFile directive to the Apache Directives in the site setup as recommended in another thread, but it came back "NOT SUPPORTED"

So I manually added the line "SSLCertificateChainFile /home/www/web6/IPS-IPSCABUNDLE.crt" to the /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf file right above the SSL Certificate lines in the virtual server conf for
<VirtualHost 66.226.75.8:443>. Then I restarted http, but still get no response to the https://wvis2.net request.

SSL doesn't seem to be working at all, and when I tried listing the compiled in modules I got this:

[root@wvis2 web6]# /usr/sbin/httpd -l
Compiled in modules:
core.c
prefork.c
http_core.c
mod_so.c

When I looked at /etc/httpd/conf/httpd.conf in loaded modules I didn't see mod_ssl.c so I am at the end of what I know to do...

Thanks ahead for any help.

Richard
Reply With Quote
Sponsored Links