View Single Post
  #1  
Old 8th September 2005, 12:58
linuxfast linuxfast is offline
Member
 
Join Date: Sep 2005
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Can't get control panel in browser

Firstly, congrats on a superb project and a superb "perfect guide for FC4".

I have successfully installed ISPConfig with no problems (using http:// for ISPConfig)
I have installed twice since, selecting the option to use the control panel through SSL (https://) and encountered the same problem.

Incidentally, the domain I have used is a FQDN but I am behind a router, as such I have a line in my hosts file which is:

192.168.1.100 www.mydomain.com www mydomain.com

This line appears both on my FC4/ISPconfig server and my local client machine.

When I put http://mydomain.com:81/ into my browser, I get as expected:
------------------------------------
Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.


Hint: https://mydomain.com:81/
------------------------------------

When I put https://mydomain.com:81 I get:

The page cannot be displayed


Any ideas ?

Just checked the logs and also tried to access the page using lynx on the server.
The logs show no requests from my machine using SSL, but shows http:// requests.
When using lynx it does the certificate thing and then goes to login.php, so obviously a network problem ?
Not sure what though !

Last edited by linuxfast; 8th September 2005 at 13:17.
Reply With Quote
Sponsored Links