View Single Post
  #7  
Old 30th July 2010, 17:06
Batmanatthenewb Batmanatthenewb is offline
Junior Member
 
Join Date: Sep 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

vuester,

Thank you for the response. I am using ISPConfig 3.0.2.2 on Ubuntu 10.04. Please see responses below.

From your post, looks like you're sure that the user and website is created correctly. As far as I know, this means for client1 the website is in /var/www/client1/web1/web/ and for client2 in /var/www/client2/web1/web/. Just want to be sure we're talking the same setting.

ANSWER: you are correct

One thing that is interesting is that I used nslookup effininsurance.com,
The results show:
Server: 192.168.0.1
Address: 192.168.0.1*53

Non-authoritative answer:
Name: effininsurance.com
Address: 68.178.232.99

What I found is:
192.168.0.1 is the internal address of one of my routers.
192.168.1.41 is the internal address for my webserver.
68.178.232.99 is the address of one of the Federal Domain name servers


Also check in ISPConfig control panel, go to tab Monitor and Show Jobqueue.
If there's some job that hasn't been completed for a while (maybe more that one hour or one day), then maybe there's some error in your previous setting. Check the log.
I say this because I notice that when there is some job that failed or hang, all the job after that will not be executed until restart.



ANSWER: Nothing in the jobqueue. No updates needed

Server: webserver1.effininsurance.com
State: ok
0 unknown | 0 info | 0 warning | 0 critical | 0 error



If that's ok then I'll continue about DNS setting.

If you use the perfect server guide, I assume you use chrooted Bind for DNS. In the tab System->Server Config->DNS, there are path for files that needs to be changed.

BIND zonefiles directory points to default /var/named, change to /var/named/chroot/var/named


ANSWER: This is what show in my DNS settings:
BIND User root
BIND Group bind
BIND zonefiles directory /etc/bind
BIND named.conf path /etc/bind/named.conf
/etc/bind/named.conf.local

What should it be changed to?


BIND named.conf path points to /etc/named.conf and /etc/named.conf.local, change to /var/named/chroot/etc/named.conf and /var/named/chroot/etc/named.conf.local

ANSWER: Used vi to read the file /etc/named.conf There is no file. There is information in /etc/bind/named.conf. It is:

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";


If you have complete DNS control for your domain, actually you can use their name server to input your server ip.


ANSWER: Using their name server is fine. I just need to get my websites back up. I Really don't care as long as it works.


But if you want to use your own name server, that's ok.
Make sure you assign your nameserver to your domain (using what everyone say a "glue record")


ANSWER: I created ns1.effininsurance.com on their website a couple days ago. It is listed as the primary name server. I used one of their name servers as a secondary, according to what the guide told me. Received a confirmation email saying it had been registered.

In my account on my Domain Registrars website ns1.effininsurance.com points to 24.106.106.99

My server is named webserver1.effininsurance.com

Network Configuration
IP Address 192.168.1.41
Netmask 255.255.255.0
Gateway 192.168.0.1
Hostname webserver1.effininsurance.com
Nameservers 192.168.0.1,192.168.0.2
Loglevel errors

I do have the "Jailkit" installed as per the guide.


Last but not least, don't forget to change the named.conf according to your setting.
Especially, in line :

listen-on port 53 { 127.0.0.1;};

allow-query { localhost; };

localhost and 127.0.0.1 needs to be changed or added with the ip or ip range that is allowed to query your server (this means which address can access your name server).
I don't know your setting because it seems you're on LAN. I use VPS so I changed the localhost and 127.0.0.1 to { any; }; which means that all address can access it.


ANSWER: named.conf has no line that says anything about "Listen" or "allow-query" It only has:

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";


The last setting makes me wait for a week with no result. Until I stumble upon some article in this forum.

That's all. Hope that helps.



Thank you for your help. Hopefully I can get this running shortly. My business website has been down for almost a week. Yes, you can laugh about Effin Insurance. But, everyone remembers the name.
Reply With Quote