View Single Post
  #6  
Old 30th July 2010, 08:29
veuster veuster is offline
Member
 
Join Date: Jul 2010
Posts: 30
Thanks: 11
Thanked 0 Times in 0 Posts
Default just sharing

I have recently installed ISPConfig 3 too, just want to share, maybe you can use it. I use CentOS 5.5, but for DNS I think it's almost the same.

From your post, looks like you're sure that the user and website is created correctly. As far as I know, this means for client1 the website is in /var/www/client1/web1/web/ and for client2 in /var/www/client2/web1/web/. Just want to be sure we're talking the same setting.

Also check in ISPConfig control panel, go to tab Monitor and Show Jobqueue.
If there's some job that hasn't been completed for a while (maybe more that one hour or one day), then maybe there's some error in your previous setting. Check the log.
I say this because I notice that when there is some job that failed or hang, all the job after that will not be executed until restart.

If that's ok then I'll continue about DNS setting.

If you use the perfect server guide, I assume you use chrooted Bind for DNS. In the tab System->Server Config->DNS, there are path for files that needs to be changed.

BIND zonefiles directory points to default /var/named, change to /var/named/chroot/var/named

BIND named.conf path points to /etc/named.conf and /etc/named.conf.local, change to /var/named/chroot/etc/named.conf and /var/named/chroot/etc/named.conf.local

If you have complete DNS control for your domain, actually you can use their name server to input your server ip.

But if you want to use your own name server, that's ok.
Make sure you assign your nameserver to your domain (using what everyone say a "glue record")

Last but not least, don't forget to change the named.conf according to your setting.
Especially, in line :

listen-on port 53 { 127.0.0.1;};

allow-query { localhost; };

localhost and 127.0.0.1 needs to be changed or added with the ip or ip range that is allowed to query your server (this means which address can access your name server).
I don't know your setting because it seems you're on LAN. I use VPS so I changed the localhost and 127.0.0.1 to { any; }; which means that all address can access it.

The last setting makes me wait for a week with no result. Until I stumble upon some article in this forum.

That's all. Hope that helps.
Reply With Quote