View Single Post
  #42  
Old 28th July 2010, 02:45
centosarus centosarus is offline
Member
 
Join Date: Apr 2009
Posts: 46
Thanks: 9
Thanked 4 Times in 3 Posts
Default Upgrade failing on one of my slave servers

Running 3.0.2.1. Upgrading to 3.0.2.2 on one slave server. Right after hitting the Enter key for the following prompt generated by the update script:

PHP Code:
MySQL master server database name [dbispconfig]: 
I received this error:

PHP Code:
PHP Fatal error:  Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 210 


Yet I successfully updated on another slave server.

php -v on the successfully updated server yielded:

Code:
PHP 5.1.6 (cli) (built: Apr  7 2009 08:00:04)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
php-v on the failed server gave:

Code:
PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator

Thanks.
Reply With Quote