View Single Post
  #1  
Old 16th July 2010, 06:33
donbzm2 donbzm2 is offline
Junior Member
 
Join Date: Jul 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Server - Ubuntu Lucid Lynx (Ubuntu 10.04) [ISPConfig 2] - Install Samba

I followed this "howto" and it is running really nice. But now I would like to install samba to share files

I tried:

sudo apt-get install samba

And set my smb.conf as (by testparm):

Code:
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[homes]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
	server string = %h server (Samba, Ubuntu)
	interfaces = eth0
	bind interfaces only = Yes
	map to guest = Bad User
	obey pam restrictions = Yes
	pam password change = Yes
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
	syslog = 0
	log file = /var/log/samba/log.%m
	max log size = 1000
	dns proxy = No
	usershare allow guests = Yes
	panic action = /usr/share/samba/panic-action %d

[homes]
	comment = Home Directories
	valid users = %S
	read only = No
	create mask = 0700
	directory mask = 0700
If I try to mount like this (dir /mnt/server created):
Code:
sudo mount -t cifs //192.168.0.100/homes /mnt/server
I get the error:
Code:
wrong fs type, bad option, bad superblock on //192.168.0.100/homes,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)

If I try to access by Nautilus:
Code:
smb://192.168.0.100
I get the error

Code:
Não foi possível montar a localização
Falha ao montar o compartilhamento Windows
My Ubuntu is pt-br, in english it would be something like:

Code:
It wasn't possible to mount location
Failed mounting Windows share
The log in /var/log/samba/log.myhost give me:

Code:
[2010/07/15 22:21:49,  0] printing/print_cups.c:103(cups_connect)
  Unable to connect to CUPS server localhost:631 - Connection refused
But I don't have cups installed, and I think nothing in my smb.conf is calling for cups...

Please, any help. Thanks.
Reply With Quote
Sponsored Links