View Single Post
Old 20th April 2006, 10:28
Wraithfire Wraithfire is offline
Join Date: Mar 2006
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts

i tried to run start firefox like this :
usr/lib/firefox/firefox-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

as i said earlier i found in /usr/lib/firefox , so i did as root:
 cp /usr/lib/firefox/ /usr/lib
and now
 ldd /usr/lib/firefox/firefox-bin
returns: => /usr/lib/ (0x00002ab1c861c000) => /usr/lib/ (0x00002ab1c87b2000) => /usr/lib/ (0x00002ab1c8999000) => /usr/lib/ (0x00002ab1c8b81000) => /usr/lib/ (0x00002ab1c8c85000) => /usr/lib/ (0x00002ab1c8d8a000) => /lib/ (0x00002ab1c8ec6000) => /lib/ (0x00002ab1c8fdb000) => /usr/lib/ (0x00002ab1c90de000) => /usr/lib/ (0x00002ab1c94e3000) => /usr/lib/ (0x00002ab1c9674000) => /usr/lib/ (0x00002ab1c9798000) => /usr/lib/ (0x00002ab1c98ae000) => /usr/lib/ (0x00002ab1c99b6000) => /usr/lib/ (0x00002ab1c9ac2000) => /usr/lib/ (0x00002ab1c9c05000) => /usr/lib/ (0x00002ab1c9d3e000) => /usr/lib/ (0x00002ab1c9e41000) => /usr/X11R6/lib/ (0x00002ab1c9fc7000) => /lib/ (0x00002ab1ca1a3000) => /usr/lib/ (0x00002ab1ca329000) => /usr/lib/ (0x00002ab1ca450000) => /usr/lib/ (0x00002ab1ca572000) => /usr/lib/ (0x00002ab1ca69c000) => /usr/lib/ (0x00002ab1ca7c1000) => /usr/lib/ (0x00002ab1ca944000) => /usr/lib/ (0x00002ab1caac9000) => /usr/lib/ (0x00002ab1cabd2000) => /usr/X11R6/lib/ (0x00002ab1cad61000) => /usr/X11R6/lib/ (0x00002ab1caec2000) => /usr/X11R6/lib/ (0x00002ab1cafca000) => /usr/lib/ (0x00002ab1cb0dc000) => /usr/lib/ (0x00002ab1cb1fe000) => /lib/ (0x00002ab1cb3db000) => /lib/ (0x00002ab1cb4e7000) => /usr/lib/ (0x00002ab1cb726000) => /usr/lib/ (0x00002ab1cb83a000) => /usr/lib/ (0x00002ab1cb97a000) => /usr/lib/ (0x00002ab1cbaa4000)
/lib64/ => /lib64/ (0x00002ab1c8506000) => /usr/X11R6/lib/ (0x00002ab1cbc95000) => /usr/X11R6/lib/ (0x00002ab1cbd98000) => /usr/lib/ (0x00002ab1cbea0000) => /usr/lib/ (0x00002ab1cbfb5000) => /usr/X11R6/lib/ (0x00002ab1cc0c0000) => /usr/X11R6/lib/ (0x00002ab1cc1ca000) => /usr/lib/ (0x00002ab1cc2e4000)

seems like it detects the file, but it still doesn't work. when i run this:
the cursor just hangs with blank return and ^c doesn't return the prompt. all other attempts to start it return the same errors as before, segmentation fault as normal user or
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

(firefox-bin:3856): Gtk-WARNING **: cannot open display:
as root or sudo

anyone have any ideas on this?
Reply With Quote