View Single Post
  #29  
Old 7th July 2010, 22:46
neutrino neutrino is offline
Member
 
Join Date: Oct 2008
Posts: 61
Thanks: 13
Thanked 9 Times in 8 Posts
Default

Hello people,

I just updated from 3.0.2.1 to 3.0.2.2 and now I have and error when trying to restart apache.

Here is the error :

Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address [::]:443
.

I've tested many things out with the 3.0.2.1 version, espacially switching to https when someone opens the http site, and I think I've been changing stuff in the vhosts or in the 000-apps or 000-ispconfig files to let it work, but I can't remember what I did.

If anyone has a small idea where I should look, it would be appreciated

Btw, netstat -tap show this :


Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:10024 *:* LISTEN 28478/amavisd (mast
tcp 0 0 localhost.localdo:10025 *:* LISTEN 28429/master
tcp 0 0 *:57993 *:* LISTEN 22938/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 28212/mysqld
tcp 0 0 localhost.localdom:7531 *:* LISTEN 5611/python
tcp 0 0 *:sunrpc *:* LISTEN 1605/portmap
tcp 0 0 www.xxxxx.xx:domain *:* LISTEN 29301/mydns
tcp 0 0 localhost.locald:domain *:* LISTEN 29301/mydns
tcp 0 0 *:ftp *:* LISTEN 29295/pure-ftpd (SE
tcp 0 0 *:ssh *:* LISTEN 1827/sshd
tcp 0 0 localhost.localdoma:824 *:* LISTEN 4040/famd
tcp 0 0 *:smtp *:* LISTEN 28429/master
tcp 0 0 *:8669 *:* LISTEN 5624/python
tcp 0 248 www.xxxxx.xx:ssh xxxxx-x-xx-xx-xxx:50025 ESTABLISHED 18439/0
tcp 0 0 localhost.localdom:7531 localhost.localdo:53743 ESTABLISHED 5611/python
tcp 0 0 localhost.localdo:53743 localhost.localdom:7531 ESTABLISHED 5624/python
tcp6 0 0 [::]:imaps [::]:* LISTEN 29226/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 29254/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 29237/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 29209/couriertcpd
tcp6 0 0 localhost:domain [::]:* LISTEN 29301/mydns
tcp6 0 0 [::]:ftp [::]:* LISTEN 29295/pure-ftpd (SE
tcp6 0 0 [::]:ssh [::]:* LISTEN 1827/sshd


edit : I remember adding a line in "I don't know what file" that was saying something like Listen on port 443, which helped the server work, but I don't remember what file that was...

Last edited by neutrino; 7th July 2010 at 22:52.
Reply With Quote