View Single Post
  #1  
Old 19th June 2010, 15:16
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 922
Thanks: 16
Thanked 259 Times in 206 Posts
Question Apps Apache vhost

The current apache ispc apps vhost looks like this:

Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig apps vhost
######################################################

 Listen 8081
# NameVirtualHost *:8081

<VirtualHost _default_:8081>
  ServerAdmin webmaster@localhost


  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  ServerSignature Off

</VirtualHost>
Because I found it useful I set up a repository and installed phpmyadmin with the ispconfig3 package manager and a simple setup.sh script.
As expected the package was installed as user ispapps in /var/www/apps/phpmyadmin

The problem is that I get a 403 when accessing any php file there.
If i comment out one of the parts in the vhost file (fcgid or modphp) it works like charm but if both sections are in there - 403 all the time.

Is there a bug in the vhost template for the apps?
Reply With Quote
Sponsored Links