View Single Post
  #1  
Old 13th June 2010, 00:55
Happy Happy is offline
Member
 
Join Date: Jun 2007
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default Setting up Software Raid1 on a system running lvm system

I am following the how to on setting up software raid1 on a running lvm system. However, I ran tinto an error when doing install for mdadm

Here is the line I copyied in
aptitude install initramfs-tools mdadm
I never got the following prompt
MD arrays needed for the root file system: <-- all

I did get the following error on the install
Generating array device nodes... /var/lib/dpkg/info/mdadm.postinst: line 27: /dev/MAKEDEV: No such file or directory
failed
I tried reinstalling and here is the output of the install

aptitude reinstall initramfs-tools mdadm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REINSTALLED:
initramfs-tools mdadm
0 packages upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 14 not upgraded.
Need to get 88.5kB/325kB of archives. After unpacking 0B will be used.
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/main initramfs-tools 0.92bubuntu78 [88.5kB]
Fetched 88.5kB in 0s (90.4kB/s)
Preconfiguring packages ...
(Reading database ... 67691 files and directories currently installed.)
Preparing to replace initramfs-tools 0.92bubuntu78 (using .../initramfs-tools_0.92bubuntu78_all.deb) ...
Unpacking replacement initramfs-tools ...
Preparing to replace mdadm 2.6.7.1-1ubuntu15 (using .../mdadm_2.6.7.1-1ubuntu15_i386.deb) ...
* Stopping MD monitoring service mdadm --monitor [ OK ]
Unpacking replacement mdadm ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up initramfs-tools (0.92bubuntu78) ...
update-initramfs: deferring update (trigger activated)

Setting up mdadm (2.6.7.1-1ubuntu15) ...
Generating array device nodes... /var/lib/dpkg/info/mdadm.postinst: line 27: /dev/MAKEDEV: No such file or directory
failed.
Removing any system startup links for /etc/init.d/mdadm-raid ...
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: mdadm start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (S)
update-rc.d: warning: mdadm stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 6)
* Starting MD monitoring service mdadm --monitor [ OK ]

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Loading one of the modules
modprobe md
FATAL: Module md not found.


From looking at it it looks like drive sdb is being used and one of the many time I rebuilt the server before getting it right I loaded sda So right now only 1 disk sdb is being used and sda has an old setup partition on it(I think). Not sure if this is related to the error?

Last edited by Happy; 13th June 2010 at 01:27.
Reply With Quote
Sponsored Links