View Single Post
  #2  
Old 11th June 2010, 20:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Your problem are the settings of your openvz / virtuozzo VM which dont allow capability switching. So it's not a general issue from pure-ftpd with Ubuntu Linux. There are two solutions:

a) If you have access to the host system, then enable capabilities for this VM by running this command:

Code:
VPSID=101
for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
do
  vzctl set $VPSID --capability ${CAP}:on --save
done

b) If you dont have access to the host system or dont want to enable capabilities, follow this FAQ (it works for ubuntu as well and not just debain):

http://www.faqforge.com/linux/contro...ities-enabled/


Regarding the /etc/fstab question. On a OpenVZ VM the quota is enabled on the host system, so you can skip that step as quota is already enabled on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote