View Single Post
  #16  
Old 26th May 2010, 18:54
Meph Meph is offline
Junior Member
 
Join Date: Jul 2009
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Not sure if afandino was able to resolve this issue or not, but I'm having the same problem under Debian 5.0 with ISPConfig 3.

I only have one SSL certificate that I use with my primary domain, so I want webmail to work by using https://www.domain.tld/webmail.

Created the symlink as follows:

ln -s /var/www/webmail/ /var/www/domain.tld/web/webmail

When I run 'grep "DocumentRoot" /etc/apache2/conf.d/sites-enabled/domain.tld.vhost' I get:

DocumentRoot /var/www/domain.tld/web
DocumentRoot /var/www/domain.tld/web

I have been looking around the web for a solution. One of them said to turn off cgi.force_redirect, but that didn't work. It was also suggested that I set a value for doc_root, but for obvious reasons that messes up my configuration. I'm under the impression that you are supposed to leave that blank when you are running virtual hosts, or maybe I just did it wrong.

Unlike afandino I am not afraid to change settings outside of ISPConfig3. I've already disabled ClamAV. For some reason the built-in SSL certificate generator doesn't work through the ISPConfig3 control panel so I had to general my private key and CSR manually.

Any suggestions?
Reply With Quote