View Single Post
  #3  
Old 23rd May 2010, 13:11
praka123 praka123 is offline
Junior Member
 
Join Date: Oct 2005
Location: Kerala,India
Posts: 14
Thanks: 3
Thanked 2 Times in 2 Posts
Post Debian ISO installing from hard disk partition:

While I wanted to install debian latest daily snapshot iso the same way ,that I learned debian iso when booted does not load all file system support.debian-installer has to loop mount the debian-iso so that to pull out the udeb's which contains the modules needed.
So,the way Ubuntu Alternate CD ISO is booted will not work with Debian testing ISO.
Here is How:


Installed Debian testing using debian-testing-amd64-netinst.iso daily built snapshot on to a ext4 partition.
Here is How I installed from CD ISO:
1) download vmlinuz and initrd.gz for hard disk boot provided by Debian team here:
For Mine ,64-bit OS ,I downloaded from amd64 folder:
http://ftp.debian.org/debian/dists/s...ages/hd-media/
I downloaded the "capable"(supports more filesystems,specifically for hard disk iso booting) Linux and initrd.gz to /dev/sdb7 /debian folder,Where "debian-testing-amd64-netinst.iso" iso also resides.

2)I'm having Ubuntu 10.04 Lucid already on another partition with Grub2 Bootloader.
I added below entry to boot the debian iso from grub2(for booting iso which is in "debian" folder on /dev/sdb7):
Code:
menuentry "Debian ISO on /dev/sdb7" {
insmod ext2
set root=(hd0,7)
loopback loop /debian/debian-testing-amd64-netinst.iso
linux  /debian/vmlinuz boot=/debian iso-scan/filename=/debian/debian-testing-amd64-netinst.iso noeject noprompt INSTALL_MEDIA_DEV=/dev/sdb7
initrd /debian/initrd.gz
}
^I don't think "INSTALL_MEDIA_DEV=/dev/sdb7" has any effect on debian-installer searching for debian ISO.But ,that's how I booted with ISO.

3) When Debian ISO Boots, It starts debian-installer(it's also a command,once booted) with ncurses based User Interface.
the installer offers to search for debian compatible isos on different hard disk partitions.It cannot search on ext4 partitions(that's what I experienced).
Knowing this ,I copied debian-testing-amd64-netinst.iso to a ext3 partition at /dev/sdb8 .
Installer searched and mounted debian-testing-amd64-netinst.iso as a loop device /dev/loop1
and install proceeds as usual.I ended up with a network enabled system also grub2 installed from the Debian.
PS:I don't know ,but when I tried loop mount or even mount ext3,ext4 partition it never worked with debian netinst cd iso!when boots it supports only a couple of file system formats like isofs,vfat(fat32).. .no ext3 also.I think ,later on ,debian-udebs(kernel modules are stored as *.udeb) containing the necessary modules has to be extracted and installed,thus ext3 and ext4 supported!

This will yield a basic Debian System with network support.

Thank You

^This is a Copy of My Post @forums.debian.net
Reply With Quote