View Single Post
  #1  
Old 8th May 2010, 17:08
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 922
Thanks: 16
Thanked 258 Times in 206 Posts
Post Get your iphone/ipod touch working with linux gtkpod (Debian testing)

As I did never write a howto before, I hope this is good enough to understand :)

I just show the steps I did to make my ipod touch working (sync video/music...) with gtkpod on my Debian testing system as the default packages did not work for me.

Note: This howto uses packages from the unstable section of debian!

Use every package and this howto at you own risk - it worked for me but that doesn't mean it will work for you. Worst case it might destroy your ipod's database.
It may be that I had some packages preinstalled so i forgot to mention them here.

Step 1 (install prerequisites):
Code:
apt-get build-dep libgpod gtkpod ifuse
apt-get install git libsqlite3-dev
Step 2 (get and install packages from sid/unstable):
http://packages.debian.org/sid/i386/...e-dev/download
http://packages.debian.org/sid/i386/...vice1/download
http://packages.debian.org/sid/i386/libplist1/download
http://packages.debian.org/sid/i386/...t-dev/download
http://packages.debian.org/sid/i386/...d-dev/download
http://packages.debian.org/sid/i386/...muxd1/download
http://packages.debian.org/sid/i386/usbmuxd/download
Code:
dpkg -i usbmuxd*.deb lib*.deb
Step 3 (get and install ifuse):
Instead of make / make install i used "checkinstall" to generate debian packages.
Code:
git clone git://git.sukimashita.com/ifuse.git
cd ifuse
./autogen.sh --prefix=/usr
make
make install
Step 4 (get and install libgpod):
Code:
git clone git://gtkpod.git.sourceforge.net/gitroot/gtkpod/libgpod
cd libgpod
./autogen.sh --prefix=/usr
make

WARNING!! amarok and some other apps use libgpod4. if you use checkinstall as i did, you have to change package name to libgpod4 and remove libgpod-common and libgpod-dev to avoid conflicts during installation.

make install
Step 5 (get and install gtkpod):
Code:
git clone git://gtkpod.git.sourceforge.net/gitroot/gtkpod/gtkpod
cd gtkpod
./autogen.sh --prefix=/usr
make
make install
Step 6 (make mountpoint and make it user-mountable - replace "myuser" with your username):
Code:
mkdir /media/ipod
chown myuser:fuse /media/ipod
usermod -a -G fuse myuser
Step 7 (prepare ipod/iphone):
You have to completely log out (even end kde or gnome) and relogin before being able to mount as user
Code:
# (re)plug in your ipod/iphone 

# mount ipod/iphone
ifuse /media/ipod

# get serial info of the device
sudo lsusb -v | grep -i iSerial
-> ea343c78a3c22dec235eca4fc40131c020babc75 (e.g.)

# read ext sysinfo and write file
ipod-read-sysinfo-extended ea343c78a3c22dec235eca4fc40131c020babc75 /media/ipod
You can now run gtkpod and (hopefully) use it!
Remember you always have to run the ifuse mount command before starting gtkpod the first time.

Plase sync your ipod/iphone with itunes on a windows pc before using it with gtkpod.

Amarok (at least v2) does still not work with ipod/iphone after following these steps - if you get it to work, please tell me how ;)



To put your ogg files on the ipod they need to be converted to mp3 - gtkpod does this if you have installed the packages "vorbis-tools" and "lame" (found in debian-multimedia).
If you get an error 6 on ogg to mp3 converting try changing
Code:
decoder="oggdec" ; options="--output - --" ;;
to
Code:
decoder="oggdec" ; options="-Q --output - --" ;;
in the file
/usr/share/gtkpod/scripts/gtkpod-convert-common.sh
Attached Images
 

Last edited by Croydon; 8th May 2010 at 17:58.
Reply With Quote
Sponsored Links