View Single Post
Old 30th April 2010, 17:07
matt_thumper matt_thumper is offline
Junior Member
Join Date: Apr 2010
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Question How to boot to the Primary Slave Drive


I have a Dell Dimension 4400 (BIOS A02) which I've upgraded over the years and it is now our secondary home computer and it's running RedHat Linux.

It has two hard drives in it, like when it used to be a Windows machine.
Then, they were C:\ and D:\.

The problem is that in order for me to successfully boot up RedHat I have to hit F12 and go into the Dell boot menu:

Boot Device Menu

1. Normal
2. Primary Master Drive
3. Primary Slave Drive
4. Diskette Drive
5. Hard-Disk Drive C:
6. IDE CD-ROM Device

7. System Setup
8. IDE Drive Diagnostics
9. Boot to Utility Partition

Enter a choice: 1

---- And there I have to change the '1' (Normal, whatever that is....) to a '3' (Primary Slave Drive ).
Then it boots up just fine.

(If I just let the Dell default-boot, it goes into a DOS-like window with GRUB in the upper-left, but GRUB doesn't accept any keyboard input)

My Dell boot sequence interface only gives me 3 options and I can't add to them:
1. Diskette Drive
2. Hard-Disk Drive C:\
3. IDE CD-ROM Device

So I don't see a way to tell it to boot from the 'Primary Slave Drive'.

Can I change the BIOS to automatically boot to the 'Primary Slave Drive'?
If so, how do I do it.

Or, how do I change RedHat to boot up automatically?

My grub.conf is:
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
title Red Hat Enterprise Linux Client (2.6.18-164.el5)
root (hd0,0)
kernel /vmlinuz-2.6.18-164.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet crashkernel=128M@16M
initrd /initrd-2.6.18-164.el5.img

Reply With Quote
Sponsored Links