Thread: IPCop
View Single Post
  #23  
Old 27th April 2010, 05:07
Elixa Elixa is offline
Junior Member
 
Join Date: Mar 2008
Posts: 6
Thanks: 0
Thanked 3 Times in 3 Posts
Default Samba & SWAT - Ports

Quote:
@dxighithall - “Is there a way to enable SWAT on ipcop without BlockOutTraffic?”
Yes, no problem.

“BlockOutTraffic” is not prerequisite for Samba … I just included a hint about how to rule “BlockOutTraffic” in the event that someone was using that plugin also (because “BlockOutTraffic” can be a pain in the a--).

If using BlockOutTraffic 3.0.0 - Build 3 ...
Port 901 had to be opened ... 'IPCop access'

… but only if, you are using “BlockOutTraffic”

The only prerequisite that was necessary for “Samba” was the changing of the gui port from 445 to something else … so that “Samba” could use that port. In my travels I came across information about a script or command, built into IPCOP, that could change the default gui port … though I have no idea where to look for it now … but that simple modification can be done with “guiports-1.6.2.tar.gz”, easily.

I see from the picture you provided that you are using port 446 to access the “Samba” page … so I can assume you did change the gui access port successfully (port 445 being needed for the share).

It’s kind of sad waiting two weeks for such a simple answer … but here it goes (sorry about the delay) …

Try using the following url … (the IP is specific to dxighithall’s example)

Quote:
HTML Code:
https://192.168.1.21:901
Upon success ... within the SWAT settings, consider disabling the printer & / or other services that you don't need (for security & resource reasons).

Good luck …& if that doesn’t work … say something & I’ll reinstall it (& then post a better response).
Hope that helped.
-

Last edited by Elixa; 27th April 2010 at 06:40.
Reply With Quote