View Single Post
  #1  
Old 13th April 2006, 17:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default Hotfix PHP segfaults ISPConfig 2.2.x

Since we updated PHP to version 5.1.2 in ISPConfig 2.2.0, I have seen a number of problems related to segmentation faults here in the forum. These segfaults have never been there with PHP 5.0.x versions.

After searching the PHP bugtracker, I found several bugs in PHP 5.1.2 that result in a segfault. It seems that PHP 5.1.2 is not as stable as the older versions and some of you got these stability issues.

Even if i can not reproduce the segfaults on my servers, I decided to make a hotfix that downgrades PHP 5.1.2 to PHP 5.0.4 in ISPConfig 2.2.0 and 2.2.1 installations. This hotfix must only be installed if you encounter one of the following problems:

1) Changes in the ISPConfig interface where not written to system config files.

2) Running the command:

/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

as root user results in a segfault.

Installation instructions:
------------------------------------------------------------

Login on the shell as root user and execute these commands:

Code:
wget http://www.ispconfig.org/downloads/compile_php_5_0_4.tar.gz
tar xvfz compile_php_5_0_4.tar.gz
cd compile_php_5_0_4
./compile
The compile script stops ISPConfig, compiles php 5.0.4 as replacement for PHP 5.1.2 and starts ISPConfig again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 13th April 2006 at 17:46.
Reply With Quote
Sponsored Links