View Single Post
Old 15th April 2010, 18:07
demortes demortes is offline
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default Upgrade from 34 -> 35 went horribly wrong


I upgraded my version of ISPConfig from 2.2.34 to 2.2.35 and now my apache wont run, my ISPconfig panel wont run. When I try, it complains about certificates not in existence.

I decided to rerun the upgrade, simply because I know I received an error, but everything completed seemingly successfully. When I rebooted, I lost the error. Now when I run it I get:

Checking the syntax of the httpd.conf...
Syntax error on line 144 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
SSLCertificateChainFile: file '/root/ispconfig/httpd/conf/ssl.crt/' does not exist or is empty
ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!
Checking that directory (/root/ispconfig) I only have the following directory structure:

And that directory is empty. I'm not sure what I did wrong, and where to begin, but I would like to maintain my websites and get this back and running.

System versions:

root@dethlefsmoreno:~/ispconfig/isp/conf/customized_templates# gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.1-4ubuntu9' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu9)

Any help, I'll appreciate.

Reply With Quote
Sponsored Links