View Single Post
  #6  
Old 15th April 2010, 16:48
alidrus alidrus is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default Another solution: Use wpa_supplicant for your WEP connection.

If you use WEP like me, here is how to solve the problem without using or installing wicd.

Firstly, test that it will work by first stopping the network manager service:

Code:
/etc/init.d/network-manager stop
This is to verify that you are running independently of network-manager.

Then edit /etc/network/interfaces like this:

Code:
iface wlan0 inet dhcp
pre-up wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf &
post-down kill -9 `pidof wpa_supplicant`
auto wlan0
Depending on your wifi card, you may need to use the -D option for wpa_supplicant.

Then, edit /etc/wpa_supplicant.conf (this will probably be created as a new file) and make it look like this:

Code:
# Static WEP keys

ctrl_interface=/var/run/wpa_supplicant

network={
	ssid="YOUR_SSID"
	key_mgmt=NONE
	wep_key0=YOUR_WEP_KEY
	wep_tx_keyidx=0
}
(The above code was modified from examples in /usr/share/doc/wpa_supplicant/examples)

Then restart networking:

Code:
/etc/init.d/networking restart
Verify that your wlan0 interface has an IP and you can ping other hosts on your LAN. If it works you may safely remove network-manager via apt-get like i did.
Reply With Quote