View Single Post
  #4  
Old 15th April 2010, 13:49
alidrus alidrus is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default Same here

I am having exactly the same problem. These used to work before I upgraded to 9.10. Now, the only way I can get wifi to work is if I click on the network manager applet in gnome and like you i wont be able to connect remotely to my office if my PC is somehow rebooted while I am away.

In my case, I have already tried manually editing /etc/network/interfaces, so I thought I must have done something wrong. So I install network-admin and configured wireless via that. The configuration that was added via the gui tool was:

iface wlan0 inet dhcp
wireless-key **********
wireless-essid ********

auto wlan0

When I tried rebooting and logging in via a text console, the interface did not come back up. dmesg showed me this:

[ 24.863155] ADDRCONF(NETDEV_UP): wlan0: link is not ready

I am pretty convinced there is some script that is failing to configure the interface properly before dhclient runs.

Please let me know if you found the solution to this problem. I have been searching the internet for some information for quite some time now and it has been frustrating.

Thanks
Reply With Quote