View Single Post
  #1  
Old 11th April 2010, 21:34
kpm kpm is offline
Junior Member
 
Join Date: Nov 2008
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default MySQL Database Replication - can't upgrade

Hi, some time ago, I set up two vps servers, one hosts web sites, the other for backup. I used Falco's great How To about mysql replication (http://www.howtoforge.com/mysql_database_replication) and the AutoMySQLBackup script for backing the live server up.
Both servers were running Ubuntu 8.10. I recently upgraded the web server from 8.10 to 9.04 then finally to 9.10. All went well with the exception of it taking me a while to find out I had to comment out "skip-bdb" on my.cnf to get MySQL up and running again.
However, I am now attempting to do the same with the backup vps but MySQL refuses to shut down. The results and error I get in the term after issuing an 'apt-get upgrade' command is:
Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2-utils apache2.2-common dhcp3-client
  dhcp3-common libapache2-mod-php5 libcups2 libcupsimage2 libexpat1 libkrb53
  libpng12-0 libpq5 libssl0.9.8 libthai-data libthai0 mysql-server mysql-server-5.0
  openssl php5 php5-cli php5-common php5-curl php5-gd php5-mysql python2.5
  python2.5-minimal sudo tzdata
29 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B/43.9MB of archives.
After this operation, 53.2kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 18393 files and directories currently installed.)
Preparing to replace mysql-server 5.0.67-0ubuntu6 (using .../mysql-server_5.0.67-0ubuntu6.1_all.deb) ...
 * Stopping MySQL database server mysqld
   ...fail!
invoke-rc.d: initscript mysql, action "stop" failed.
invoke-rc.d returned 1
There is a MySQL server running, but we failed in our attempts to stop it.
Stop it yourself and try again!
dpkg: error processing /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6.1_all.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Can someone point me in the right direction?
Thanks
Reply With Quote
Sponsored Links