Thread: IPCop
View Single Post
  #22  
Old 11th April 2010, 02:37
dxighithall dxighithall is offline
Junior Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default Samba SWAT on ipcop

Elixa,
Is there a way to enable SWAT on ipcop without BlockOutTraffic?

Here is an screenshot what I'am seing right now
http://img140.imageshack.us/img140/1...xecuteswat.jpg


Quote:
Originally Posted by Elixa View Post
samba-0.2.1.tar.gz


From www.h-loit.de (www 'dot' h-loit 'dot' de) *(German only)

For those who cannot download from original source good luck ... as 18 mb was too large to upload here.

Included modification info below that is necessary for installation into IPCOP v1.4.20 ... updated to IPCOP v1.4.21

To use samba-0.2.1.tar.gz the default IPCOP access port must be changed from port 445 to something else easily accomplished by using guiports-1.6.2.tar.gz

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

Copy samba-0.2.1.tar.gz


to /tmp/bot1/ (example)

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

Enter terminal command:


tar -zxvf samba-0.2.1.tar.gz

(before next step ... see modification below)


Command had to be executed from the console. (local machine)


./install -i

during install enter ... for example * (your personal network range) ... 192.168.0.0/16

later ... in the gui (global settings, advanced view) ...

... allow ... 192.168.0.0/16 *(your personal network range ... could be different)
... deny ... 0.0.0.0/0 *(these settings keep access limited to your personal network)

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

For ... IPCOP v1.4.20 ... updated to (IPCOP v1.4.21)


edit install ... line 705

change '2.4.34' to '2.4.36'

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

To view and use the addon go to IPCop/Services/Samba Server/


Check 'enable Samba Server ?' ...
... click 'save' ... then click 'start'.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

To login into the SWAT settings use the username and password for root user of IPCOP.

If using BlockOutTraffic 3.0.0 - Build 3 ...
Port 901 had to be opened ... 'IPCop access'

Default shared folder 'files'

Default username and password for shared folder 'samba:samba'




Enjoy ;-)
Reply With Quote