View Single Post
  #11  
Old 3rd April 2010, 14:06
abhandari abhandari is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dovecot IPv4 only imap 143 failed

Boss,

This is based on CentOS5.4 + dovecot dovecot-1.2.11-3.0.cf.rhel5

I have the same error. But nothing figured out correctly. I have actually disabled the IPV6 from /etc/modprobe.conf
---------------
alias ipv6 off
alias net-pf-10 off
---------------

and

# touch /etc/modprobe.d/disable-ipv6
# echo "install ipv6 /bin/true" >> /etc/modprobe.d/disable-ipv6
------------------

#chkconfig ip6tables off
-----------------
=============
then. In that situation i have normally configured the dovecot and tryed to restart the dovecot service and have the error: like urz.:-
===============================
[root@smail certs]# service dovecot start
Starting Dovecot Imap: If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.
Fatal: listen(::, 143) failed: Address already in use
[FAILED]
[root@smail certs]# service dovecot start
Starting Dovecot Imap: Fatal: listen(::, 143) failed: Address already in use
[FAILED]
[root@smail certs]# service dovecot start
Starting Dovecot Imap: Fatal: listen(::, 143) failed: Address already in use
[FAILED]
[root@smail certs]# service dovecot start
Starting Dovecot Imap: Fatal: listen(::, 143) failed: Address already in use
[FAILED]

================================

Amazing u have the solution after some hit and trial:

Change the line below from /etc/dovecot.conf

which only listens to your IPV4 addresses for your pop/s imap/s
=========
#listen = *, [::]
to
listen = *
=========

Now restart ur dovecot ---perfectly works man
=========
[root@smail ~]# service dovecot restart
Stopping Dovecot Imap: [FAILED]
Starting Dovecot Imap: [ OK ]
-================
Reply With Quote
Sponsored Links