View Single Post
  #1  
Old 30th March 2010, 04:36
Meph Meph is offline
Junior Member
 
Join Date: Jul 2009
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
Default Disable and remove ClamAV

Update: My original post was incorrect. Here is the correct procedure: (Works in Debian 5)

edit /etc/amavis/conf.d/50-user

Comment out the following two lines:

Code:
@bypass_virus_checks_maps = (
   \%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);
Looks like this:

Code:
#@bypass_virus_checks_maps = (
#   \%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);

@bypass_spam_checks_maps = (
   \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);
Restart amavis:

/etc/init.d/amavis restart

Stop clamav:

/etc/init.d/clamav-daemon stop
/etc/init.d/clamav-freshclam stop

Disable clamav from running on system boot:

update-rc.d -f clamav-daemon remove
update-rc.d -f clamav-freshclam remove

Quote:
Original Post:


I'm running Debian 5 and ISPConfig 3. I only have 512mb of ram so I want to disable clamav and free up that memory.

I tried to follow the instructions in this post:

http://www.howtoforge.com/forums/sho...22&postcount=8

Except I used update-rc.d to remove the symbolic links instead of chkconfig.

update-rc.d -f amavis remove
update-rc.d -f clamav-daemon remove
update-rc.d -f clamav-freshclam remove

When I do this my outgoing server stops working. I can connect and send a message, but it never gets delivered. I also noticed that when I reversed the directions and re-enabled clamav, all the emails I tried to send when clamav was disabled were suddenly delivered.

Also, is there a setting in ISPConfig3 to change it from warning you when clamav isn't running? Perhaps that is in the documentation and I should look it up, but I really would like to know how to disable it without fubaring my SMTP server.

Last edited by Meph; 5th April 2010 at 10:27. Reason: Solution found!
Reply With Quote
Sponsored Links