View Single Post
  #3  
Old 29th March 2010, 22:17
wpwood3 wpwood3 is offline
Senior Member
 
Join Date: Oct 2007
Location: Atlanta, GA USA
Posts: 197
Thanks: 21
Thanked 30 Times in 20 Posts
Post My solution

Thanks for your quick reply, Till. You got me pointed in the right direction.

Here's what I did. Please let me know if you see any problems with my approach.

Create a new Apache config file for munin:
Code:
 
vi /etc/httpd/conf.d/munin.conf
Insert the following lines into the file:
Code:
 
Alias /munin /var/www/munin
<Directory "/var/www/munin">
    Options Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
Restart Apache:
Code:
 
/etc/init.d/httpd restart
Create a new folder and give ownership to munin:
Code:
 
mkdir /var/www/munin
chown -R munin:munin /var/www/munin
Edit the munin config file to point to the new folder:
Code:
 
vi /etc/munin/munin.conf
change htmldir to point to /var/www/munin:
Code:
 
htmldir /var/www/munin
Secure /var/www/munin with .htaccess

Now I can access munin from http://www.mytestsite.com/munin
__________________
CentOS 5.4 64bit (the Perfect Setup)
ISPConfig 2.2.40
WP3 Photography
Reply With Quote