View Single Post
  #10  
Old 24th March 2010, 20:50
jwlinux jwlinux is offline
Junior Member
 
Join Date: Mar 2010
Posts: 27
Thanks: 5
Thanked 2 Times in 2 Posts
Default

" I do notice 'snoopy' and 'unknown UID:' in your logs. The unknown user ID seems wrong. "

It actually doens't say "unknown UID", is says "unknown, uid:5004." unknown refers to some other field of information, I'm not sure what.

uid:5004 was the users's UID in /etc/password, that part is correct (or was at the time).

I also noticed that the user's directory tree files under web/ are owned by, for example:

drwxr-xr-x 2 1061 users 216 2010-03-24 04:55 error

and no such user 1061 exists in /etc/password. I don't know where it got 1061 from. I wonder if it's trying to use that in other places (such as while creating a shell user) and that's what's breaking it.

"Also what is 'snoopy' doing? I don't know the answer. Just things to look into."

Snoppy is a logging function. I have been using it for years on all kinds of servers, it works good, and is transparent to all programs. I'm sure there is some 0.01% possibility that snoopy is causing a problem but it is very, very unlikely.

Till: please tell me where I can look or what tests I ran run to try to find _why_ the jailkit user is not being created correctly.

On one of my two ISPConfig servers I also tried doing the automatic upgrade to 3.0.2.1, because I saw elsewhere on the forum that this was recommended in a few cases to fix jailkit problems.

I tried creating new sites and shell users after the upgrade, and it is still the same.

Thank you every one for your help,

JW
Reply With Quote